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HCITester Tool

This user's guide describes how to use the HCITester software tool with TI's wireless Bluetooth® devices
(BL6450, CC256x, WL127x, WL128x, and WL18xx), including how to send and receive HCI scripts using
HCI commands and events.
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1 Requirements

1.1 System Requirements
The HCITester tool requires the following components:
• Minimum requirements: PC running Pentium II
• Operating systems: Windows® 2000, Windows XP, Windows 7
• Access to Bluetooth HCI pins
• Access to Bluetooth HCI UART lines
• For Bluetooth TX validation, standard RF equipment (such as a power meter, spectrum analyzer,

vector signal analyzer, or a combined tester such as Litepoint™ IQxel™) for TX output power,
Bluetooth mask, and DEVM measurements.

• For Bluetooth RX validation, a vector signal generator to generate Bluetooth packets for the IC to
analyze.

Debug and calibration tools for WLAN and Bluetooth® require four UART ports. The most efficient way to
drive these ports to the PC is to use a UART-to-USB converter (not included in the wireless tools
package). TI recommends using the WL18XXCOM82SDMMC adapter with the TI WL1837MODCOM8I
module or the WL1835MODCOM8B module on the COM8 board.

NOTE: Multiple UART-to-USB adapters are available on the market, such as the FTDI Chip™
development modules.

1.2 Configuration Requirements
The HCITester tool for the WiLink™ 8 TI Bluetooth release requires the latest versions of the following
configuration files:
• XML file
• Bluetooth script

NOTE: The XML file and the Bluetooth script support all of the WiLink family and are based on the
BTS naming format; for information on the WL128x and prior releases, follow the README
file.

The installation files are in the directory named Wireless Tools at the installation path configured during
installation. By default, the files are at the following path:

C:\Program Files (x86)\Texas Instruments\Wireless Tools

NOTE: Throughout this document, the directory in which the installation files reside is referred to as
Installation directory.

2 Installation
The HCITester application is part of the TI wireless tools package release. When the wireless tools
package is installed, the HCITtester icon is created in the Texas Instrument\Wireless Tools folder at
Start→Programs and on the desktop (see Figure 1).

Figure 1. HCITester Icon
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To start the HCITester, double-click the HCITester icon. The software initializes and displays the
HCITester working window (see Figure 2).

Figure 2. HCITester Working WIndow

3 Post Installation Requirements

3.1 Changing the XML File
TI Bluetooth devices require specific XML files. To change the XML file to match your specific TI Bluetooth
device, perform the following steps:
1. From the toolbar, open the View menu and select Command Library. The Command Library pane

appears (see Figure 3).

Figure 3. Command Library Pane
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2. To open the Change Library Files dialog box, click the Change Library button (for more information on
the Change Library button, see Table 11). The Change Library Files dialog box displays (see
Figure 4).

Figure 4. Changing the XML File

3. Select the appropriate XML file for your device. and click OK.

NOTE: Select only one XML file at a time.

Table 4 describes the XML file changing functions.

Table 1. XML File Changing Icon Functions

Icon Function

Create a new file

Browse to the location of a saved file

Delete a file from the list

Move a file up in the list

Move a file down in the list
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3.2 Firmware Initialization Script (.BTS file)
The BTS file or initialization script must be modified to work with HCITester. Perform the following steps to
modify the BTS file for HCITester:
1. Open HCITester tool.
2. Open the BTS file (File→ Open).
3. Create a new script (File→ New).
4. Copy the contents of the BTS file into the new tab.
5. Click Edit→ Replace→ Replace All and replace 0x00 in the Number of HCI Commands parameter with

any (see Figure 5).

Figure 5. Editing the BTS File for Use in the HCITester Tool

6. Save that script as the new initialization file in TXT format.

NOTE: Run this initialization file before running any scripts on the module.

7. Click Execution→ Execute to run the initialization file.

3.3 Updating the Scripts Pane
The Scripts pane contains all the script files from the chosen root file. Figure 6 shows the Scripts pane.

Figure 6. Scripts Pane

6 HCITester Tool SWRU136B–November 2007–Revised September 2015
Submit Documentation Feedback

Copyright © 2007–2015, Texas Instruments Incorporated

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SWRU136B


www.ti.com HCITester Features

To search the Scripts pane, use the incremental search function in the following ways:
• To locate the desired script, type a partial text string.
• To search forward, press the F3 function key.
• To search backward from the present location, press Shift+F3.

Table 2 describes the Scripts pane functions.

Table 2. Scripts Pane Icon Functions

Icon Function

Refresh the contents of the Script pane

The Scripts pane lists all available scripts. You can choose any script to be
loaded, executed, and edited. By default, the list of HCITester scripts is empty
after software installation.

To update the pane, perform the following steps:
1. Press Open on the scripts pane.
2. Select the scripts folder.

4 HCITester Features
This section summarizes the features of the HCITester software.

4.1 Port Connection Options
The port connection Options dialog box enables configuration of the specific type of communication
between the HCITester and the device. Figure 7 shows the port connection Options dialog box.

Figure 7. Configuration of the Port Connection

The port connection Options dialog box includes the following tabs:
• None: No connection is established between the HCITester software and the device.
• Serial: Connects a serial port connection with the device. This connection supports various types of

flow control and power mode (sleep) controls.
• Squirt: Connects to the device using a squirt serial connection in parallel with other applications using

a squirt port (such as Logger)
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• TCP/IP: Connects to the device over all types of TCP/IP protocol (synchronized or not, servers, or
clients)

NOTE: When selecting serial or squirt port connections, remember to select the port number,
desired baud rate, flow control, and sleep type.

The default device baud rate is 115200 but can be configured up to 3MB using the HCI switch baud rate
vendor-specific (VS) command. For more information, see the Bluetooth (WL18xx and WL18xxQ) Vendor-
Specific HCI Commands User's Guide (SWRU303).

4.1.1 Flow Control Options
Table 3 summarizes the flow control options.

Table 3. Flow Control Options

Option Result
None Flow control is not used.
Hardware CTS/RTS flow control
Packet Wise Reserved
Negotiate Reserved
Segmentation Reserved
Three Wire Software flow control (Xon/Xoff)

4.1.2 Sleep Type Options
HCITester supports three sleep protocols:
• HCILL
• Palau
• ThreeWire (set automatically if ThreeWire flow control is selected)

Table 4 describes the sleep type functions.

Table 4. Sleep Type Functions

Icon Function
HCITester automatically controls the power mode of the
device. The software is set to sleep on a timeout and awake if
required.Auto Control The SetAutoSuspend script command controls this feature.
The SetSuspendTimeout command sets the idle timeout value.
The default value is 2000 ms.
The user sets the power mode manually. Click to set the
device in sleep mode or to awake from sleep mode.Manual Control The SetAutoState command is a script command that controls
this feature.
Status bar indicator showing when the host (that is, theStatus HCITester) is in sleep mode.
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4.2 Main Interface Screen Overview
Figure 8 shows the names of the areas and functions that make up the HCITester main interface window

Figure 8. HCITester Main Interface Window
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4.3 Executing Scripts or Commands

4.3.1 Executing Scripts
Executing a script involves three steps:
• Loading the script
• Editing the script (as required)
• Running the script

4.3.1.1 Loading the Script
A script can be loaded in the following ways:
• Select Open Script… from the File menu.

• To select a previously used script, click the Load icon ( ) on the toolbar button.
• Double-click the requested script in the scripts pane.

4.3.1.2 Editing a Script
To edit a script, select a line of the script in the Edit script View window and change the values.
Alternatively, edit scripts in the values in the Values pane. This option automatically updates the text in the
script.

The Script Editor functions similarly to any other text editor. To copy, cut, and paste lines in the script or
from one script to the other, right-click and select the desired option from the pop-up menu. The basic
Control (Ctrl) commands to copy (Ctrl+C), cut (Ctrl+X), and paste (Ctrl+V) selected text are also available.

4.3.1.3 Executing a Script

After loading to the script editor pane, a script can be executed by clicking the Start icon ( ) on the
toolbar or pressing the F5 button on the keyboard.

To stop a running script, click the Stop button ( ) on the toolbar or press F5 again.

The Trace Port view displays the output of the running script.

4.3.2 Executing Commands

4.3.2.1 Searching for a Specific Command in the Command Library
To search for a specific command in the Command Library, follow these stepsFigure 9:
1. Place the curser on any command in the Command Library.
2. Type a key phrase from the command in the Incremental Search field.
3. Press F3 to scroll between all the commands that contain the phrase within them (SHIFT+F3 searches

backwards).
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Alternatively, use the toolbar button to select one of the previously used commands for execution.

Figure 9 shows a search for the word sleep.

Figure 9. Searching For a Command in the Command Library

4.3.2.2 Executing a Single Command
Select the desired command in the Command Library pane. Right-click the desired command and select
the desired option from the pop-up menu: Execute; Add the command to a currently active script; or Add
the command to your list of shortcuts.

Figure 10 shows an example of this selection.

Figure 10. Executing a Single Command from the Command Library

Double-clicking a command line in the Command Library Pane also executes the command. A third way to

execute a command is to press the icon (as explained in Section 4.6, Values Pane).
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4.3.3 Execution Shortcut-Keys and Status Indicators
There are three shortcut keys when working with scripts.

• (F5): Execute current script

• (F5): Stop running current script

• (Ctrl+F5): Execute only current selection:
– Selected script text
– Current line (if no text selected)
– Current command in Values pane

A complete list of shortcuts is provided in Appendix A, List of Shortcuts.

As Figure 11 shows, there are also four possible execution status indicators displayed in the status bar.

Figure 11. Execution Status Indicators

Table 5 summarizes the execution status indicators.

Table 5. Execution Status Indicators

Icon Description

Running Normal indicator; the script or command is running

Failed Shows that the previous script or command failed

Port Indicates the COM port that is in use

Sleep Sleep indicator
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4.4 ToolBar and Main Menus

4.4.1 Menu Bar and Toolbar
Figure 12 shows the menu bar and toolbar. Table 6 summarizes the program commands and functions
available using the toolbar icons.

Figure 12. HCITester Menu Bar and Toolbar

Table 6. HCITester Menu Functions

Icon Function

Open a new script in the Scripts pane

Open a new screen to browse through files on the PC.

Save the active script

Cut selected text to the clipboard

Copy selected text to the clipboard

Paste selected text from the clipboard to the present cursor location

Print the active script or selection

Execute the active script

Stop executing the active script

Execute a selected part of the active script

Clear the Trace pane display

Configure various display and command options

Configure the HCITester software to automatically wake up the device from sleep mode

Put the device into sleep mode

Execute the most recent command

Load and execute the most recent script
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4.4.2 Drop-Down Menus

4.4.2.1 File Commands
Figure 13 shows the File drop-down menu.

Figure 13. File Command Drop-Down Menu

Table 7 summarizes the File menu command functions.

Table 7. File Command Drop-Down Menu Functions

Command Shortcut Function
New Ctrl+N Open a new file (script)

Open an existing (saved) script. This option opens a new screen toOpen script Ctrl+O browse through files on the PC
Close Close a currently open script
Save Ctrl+S Save the currently active script

Save the currently active script under a different name. This option
Save As opens a new screen from which to enter a new file name and select a

location to save the file.
Print Ctrl+P Print the currently active script
Print Preview Preview the file to be printed
Print Setup Open a new screen to configure printing options on the PC

Export the Trace log as an HTML file. This option opens a newExport Trace screen from which to enter a new file name and select a location toLog export the file.
Exit Exit the HCITester application
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4.4.2.2 Edit Commands
The Edit menu contains actions that relate to editing scripts. Figure 14 shows the Edit drop-down menu.

Figure 14. Edit Command Drop-Down Menu

Table 8 summarizes the Edit command functions.

Table 8. Edit Command Drop-Down Menu Functions

Command Shortcut Function
Undo Ctrl + Z Undo last action
Redo Repeat last action
Cut Ctrl + X Cut selected text
Copy Ctrl + C Copy selected text to clipboard
Paste Ctrl + V Paste selected text from clipboard
Select All Ctrl + A Select all text in currently active script
Find Ctrl + F Find selected text or item
Replace Ctrl + H Replace selected text with new text
Line Numbers Add line numbers to the currently active script
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4.4.2.3 View Commands
The View menu contains commands related to how the HCITester software displays the currently active
script file. Figure 15 shows the View menu.

Figure 15. View Command Drop-Down Menu

Table 9 summarizes the View menu command functions.

Table 9. View Command Drop-Down Menu Functions

Command Function
Options Trigger the Options screen (see Section 5, Setup and Configuration)

Enable the selection of different looks for the HCITester based on theApplication Look selection in the screen that is triggered
Enable customization of the HCITester menus and buttons based onCustomize user-defined parameters
Restore the program to default view options (requires exiting andRestore to default windows layout restarting the HCITester software)
Toggle the SLEEP state of the connected Bluetooth device (This

Toggle Sleep Indicator function is identical to the function of the Device Sleep icon located on
the toolbar.)
Enable a hex view of the incoming data from the Bluetooth device toHex Dump of Incoming Data the host
Enable a hex view of the outgoing data from the host to the BluetoothHex Dump of Outgoing Data device

Command Library
Scripts
Trace Display or hide specific panes in the active windowValues
Shortcuts
General Toolbar
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4.4.2.4 Window Commands
Figure 16 shows the Window drop-down menu.

Figure 16. Window Menu Drop-Down Menu

Table 10 summarizes the Window menu command functions.

Table 10. Window Command Drop-Down Menu Functions

Command Function
Cascade

These commands are not enabled in the current release of theTile HCITester software.
Arrange Icons

These markers indicate the active panes of the currently active1, 2, etc. HCITester session.

4.4.2.5 Help Commands
The Help menu contains an option for the user to read about the HCITester software (as shown in
Figure 17).

Figure 17. Help Command Drop-Down Menu
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4.5 Command Library Pane
The Command Library pane, shown in Figure 18, contains a list of all the supported commands and
events.

Figure 18. Command Library Pane

To search the Command Library, use the incremental search function as follows: Type a string of partial
text to locate the desired command. Press F3 to search forward and Shift+F3 to search backward from the
present location (for more information about the incremental search feature, see Section 4.3.2.1,
Searching for a Specific Command in the Command Library).

To add the command (along with any related commands) to the active script, hold down the Ctrl key and
double-click the left mouse button, or use the right mouse button pop-up menu (for more information, see
Section 4.3.2.2, Executing a Single Command).

Table 11 summarizes the three Command Library functions.

Table 11. Command Library Icon Functions

Icon Function

Refresh Refresh the contents of the Command Library pane

Change the HCI Library. Use this button to change between
Change different XML files (for more information, see Section 3.1,

Changing the XML File).
Filters the contents of the Scripts pane. Pressing this iconFilter displays the Visible Categories dialog box (see Figure 19).
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Figure 19 shows the Visible Categories dialog box.

Figure 19. Visible Categories Dialog Box

4.6 Values Pane
The Values pane displays the values of the currently selected command (see Figure 20).

Figure 20. Values Pane

The Values pane reflects the command selected in the Command Library pane or a selected line in the
script Editor pane. When the Values pane shows a script line in the Editor, changing a value in the script
also changes the script text.

Table 12 describes the Values pane command functions.

Table 12. Values Pane Command Functions

Icon Shortcut Function

Ctrl + F5 Execute the listed command

Add the listed command to the active script
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4.7 My Shortcuts Pane
The My Shortcuts pane allows quick access to predefined script files and code fragments (see Figure 21).

Figure 21. My Shortcuts Pane

To create a shortcut, follow these steps:
• To create a shortcut to a script file, Drag the desired script from the Scripts pane or from the Explorer

window to the Shortcuts pane.
• To create a shortcut to a code fragment, Drag the selected code in the Editor to the Shortcuts pane.

The following commands are available from the Shortcut pane:
• Run and/or Load: Right-click and select Edit… to specify the desired behavior while clicking on this

shortcut.
• Display name: Right-click and select Edit… to specify a customized label.
• Right-Click menu: Explicitly Run, Load, Delete, or Edit the shortcut properties.
• Shift + Click: Run the selected shortcut.
• Ctrl+ Click: Load the selected shortcut.
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4.8 Script Editor Pane
The Script editor pane displays the currently loaded script to execute. While a script is executed, the
executed line is highlighted at the bottom of the pane.

More than one script can be loaded into the Script Editor pane. To toggle between the scripts, select the
tab of the desired script. For more information regarding loading, editing, and executing scripts, see
Section 4.3.1, Executing Scripts.

Figure 22 shows the Script Editor pane.

Figure 22. Script Editor
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4.9 Trace Pane
The Trace pane displays the commands, events, and raw data communication of the HCITransport
program. Figure 23 shows the Trace pane.

Figure 23. Trace Pane
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The following display options are available in the Trace pane:
• Customize Colors: Select the Trace option in the Options dialog box (for information on customizing

the font and display colors of the trace elements, see Section 5.3, Trace).
• Automatic Save to File: Select the Log option in the Options dialog box (for information on log file

configuration options, see Figure 29).

Table 13 describes the Trace pane icon functions.

Table 13. Trace Pane Icon Functions

Icon Function
Export the Trace log file to a different location. This option

Export Trace Log opens a new screen for selecting a new name for and location
to save the file.

Clear Trace Pane Clear the Trace pane display.

Automatic Scroll Automatically scrolls through the active script.

To trace the raw data of a running command or script, select Hex Dump of Incoming Data or Hex Dump of
Outgoing Data from the View menu for the selected COM port. Figure 24 shows the View menu.

Figure 24. Selecting Raw HCI Data to Trace on the View Menu

After the menu option is selected, all data transferred through the UART interface are visible in the Port
Trace View window.
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5 Setup and Configuration Using the Options Window
The Options window controls software setup and configuration and is available from the View menu (see
Section 4.4.2.3, View Commands).

5.1 Network Configuration Option
The Network configuration option enables multiple HCITester applications running on different machines to
be linked on the same network domain.

To bind multiple HCITester applications, specify a group name and check the Network Control Active box,
as shown in Figure 25.

Figure 25. Network Configuration Option

When multiple HCITester applications are in the same network group, the programs start operating
together. When Stop is clicked on one program, all running programs stop.

The status bar indication shown in Figure 26 displays a unique name given to the running process and the
group name.

Figure 26. Status Bar Indicator for Network Configuration
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5.2 Editor Option
The Editor option allows the font and display colors of the Editor elements to be customized
(seeFigure 27).

Figure 27. Editor Configuration

5.3 Trace Option
The Trace configuration option allows the font and display colors of the trace elements to be customized
(see Figure 28).

Figure 28. Trace Configuration Option
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5.4 Log File Configuration Options
The log file option automatically saves the trace window contents while a script is running. Figure 29
shows the log file configuration options.

Figure 29. Log File Configuration Options

Table 14 summarizes the log configuration options.

Table 14. Log Configuration Options

Option Result
File Name Three types of file extensions are allowed:

.txt (plain text file)

.htm (HTML formatted file)

.xml (XML data file information)
Append If this box is checked, then new log traces are appended to the existing file. Otherwise,

a file is created each time a new script is executed.
Prepend Adds currently displayed events to the active log file.
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List of Shortcuts

Table 15. Available HCITester Shortcuts

Command Action
F5 Execute or Stop script execution
Ctrl+F5 Execute current selection
F11 Execute last command
F12 Switch to last executed script
Ctrl+F11 Pop-up a list of recently-used commands
Ctrl+F12 Pop-up a list of recently executed scripts
F8 Clear Trace
Editor Commands
Ctrl+C Copy selection to clipboard
Ctrl+V Paste from clipboard
Ctrl+X Cut selection to clipboard
Ctrl+F Pop-up Find dialog box
Ctrl+H Pop-up Replace dialog box
F3 Repeat last search
Shift+F3 Repeat last search backwards
Ctrl+F3 Search for current word
Ctrl+A Select all text
Ctrl+Z Undo last action
Ctrl+Y Redo the previously undone action
File Commands
Ctrl+N Create a new script
Ctrl+O Open an existing script file
Ctrl+P Print the current script
Ctrl+S Save the current script
Ctrl+F6 Switch to the next script
Ctrl+Shift+F6 Switch to the previous script
Undocumented Commands

Resets the COM port in cases when an error on the H4 protocol
causes the port to get stuckCtrl +

Ctrl+Shift+ Numpad- Switch RTS on the serial port
Ctrl+Shift+ Numpad+ Switch DTR on the serial port
Ctrl+0..9 Run pre assigned scripts 0 to 9

Add Shift for 10 to 19
Ctrl+Alt+0..9 Assign a script 0 to 9.

Add Shift for 10 to 19
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Terms and Abbreviations

Table 16 lists terms and abbreviations.

Table 16. Terms and Abbreviations
Term Description

BD_ADDR Bluetooth device address

BER Bit error rate

BT Bluetooth

HCI Host controller interface

Host/host PC A PC connected to the device through the serial port

LMP Link manager protocol

LQM Link quality monitor

PER Packet error rate

RF Radio frequency

RSSI Received signal strength indication

SW Software

VS Vendor-specific
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IMPORTANT NOTICE

Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, enhancements, improvements and other
changes to its semiconductor products and services per JESD46, latest issue, and to discontinue any product or service per JESD48, latest
issue. Buyers should obtain the latest relevant information before placing orders and should verify that such information is current and
complete. All semiconductor products (also referred to herein as “components”) are sold subject to TI’s terms and conditions of sale
supplied at the time of order acknowledgment.
TI warrants performance of its components to the specifications applicable at the time of sale, in accordance with the warranty in TI’s terms
and conditions of sale of semiconductor products. Testing and other quality control techniques are used to the extent TI deems necessary
to support this warranty. Except where mandated by applicable law, testing of all parameters of each component is not necessarily
performed.
TI assumes no liability for applications assistance or the design of Buyers’ products. Buyers are responsible for their products and
applications using TI components. To minimize the risks associated with Buyers’ products and applications, Buyers should provide
adequate design and operating safeguards.
TI does not warrant or represent that any license, either express or implied, is granted under any patent right, copyright, mask work right, or
other intellectual property right relating to any combination, machine, or process in which TI components or services are used. Information
published by TI regarding third-party products or services does not constitute a license to use such products or services or a warranty or
endorsement thereof. Use of such information may require a license from a third party under the patents or other intellectual property of the
third party, or a license from TI under the patents or other intellectual property of TI.
Reproduction of significant portions of TI information in TI data books or data sheets is permissible only if reproduction is without alteration
and is accompanied by all associated warranties, conditions, limitations, and notices. TI is not responsible or liable for such altered
documentation. Information of third parties may be subject to additional restrictions.
Resale of TI components or services with statements different from or beyond the parameters stated by TI for that component or service
voids all express and any implied warranties for the associated TI component or service and is an unfair and deceptive business practice.
TI is not responsible or liable for any such statements.
Buyer acknowledges and agrees that it is solely responsible for compliance with all legal, regulatory and safety-related requirements
concerning its products, and any use of TI components in its applications, notwithstanding any applications-related information or support
that may be provided by TI. Buyer represents and agrees that it has all the necessary expertise to create and implement safeguards which
anticipate dangerous consequences of failures, monitor failures and their consequences, lessen the likelihood of failures that might cause
harm and take appropriate remedial actions. Buyer will fully indemnify TI and its representatives against any damages arising out of the use
of any TI components in safety-critical applications.
In some cases, TI components may be promoted specifically to facilitate safety-related applications. With such components, TI’s goal is to
help enable customers to design and create their own end-product solutions that meet applicable functional safety standards and
requirements. Nonetheless, such components are subject to these terms.
No TI components are authorized for use in FDA Class III (or similar life-critical medical equipment) unless authorized officers of the parties
have executed a special agreement specifically governing such use.
Only those TI components which TI has specifically designated as military grade or “enhanced plastic” are designed and intended for use in
military/aerospace applications or environments. Buyer acknowledges and agrees that any military or aerospace use of TI components
which have not been so designated is solely at the Buyer's risk, and that Buyer is solely responsible for compliance with all legal and
regulatory requirements in connection with such use.
TI has specifically designated certain components as meeting ISO/TS16949 requirements, mainly for automotive use. In any case of use of
non-designated products, TI will not be responsible for any failure to meet ISO/TS16949.
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Audio www.ti.com/audio Automotive and Transportation www.ti.com/automotive
Amplifiers amplifier.ti.com Communications and Telecom www.ti.com/communications
Data Converters dataconverter.ti.com Computers and Peripherals www.ti.com/computers
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Clocks and Timers www.ti.com/clocks Industrial www.ti.com/industrial
Interface interface.ti.com Medical www.ti.com/medical
Logic logic.ti.com Security www.ti.com/security
Power Mgmt power.ti.com Space, Avionics and Defense www.ti.com/space-avionics-defense
Microcontrollers microcontroller.ti.com Video and Imaging www.ti.com/video
RFID www.ti-rfid.com
OMAP Applications Processors www.ti.com/omap TI E2E Community e2e.ti.com
Wireless Connectivity www.ti.com/wirelessconnectivity
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