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bq27x00 Single-Cell Battery Fuel Gauge Module
Tester and Programmer

The Texas Instruments bq27x00 Tester Kit tests and programs bq27000 and bq27200
single-cell Li-ion and Li-polymer battery gas gauge devices. The kit includes a bq27x00
Test and Program PC interface board for gas gauge testing, one RS-232 cable, a CD
ROM including Windows™-based PC software, and support documentation.
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The Texas Instruments bq27x00 Tester Kit tests and programs bq27000 and bq27200 single-cell Li-ion
and Li-polymer battery gas gauge devices. The kit includes a bq27x00 Test and Program PC interface
board for gas gauge testing, one RS-232 cable, a CD ROM including Windows™-based PC software, and
support documentation. This kit tests the electronic modules prior to pack installation.

• Complete test and program system for the bq27000 and bq27200 battery gas gauge
• PC software and interface board for production test
• Software allows EEPROM programming and production data logging.

1. HPA048 PC interface test board (bq27x00 Test and Program) for RS-232
2. CD ROM including Windows-based PC software and support documentation
3. RS-232 cable

Windows is a trademark of Microsoft Corporation.
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1.3 Ordering Information

2 Installation and Setup

2.1 Minimum System Requirements

2.2 Final Test Board Specifications

2.3 Interface Connections

Installation and Setup

Kit Part Number PC Interface Board Chemistry Pack Voltage

bq27x00 Tester-Kit RS-232 Li-ion 2.6 V to 4.5 V

• Operating system: Windows 98, 2000, or XP
• Video: Super VGA– 1024 × 768 minimum resolution
• RAM: 16M bytes
• Hard drive space: 5M bytes
• RS-232 port: 1 available

• +9 V to +12 V DC minimum 1 A
• Analog inputs: ±6 V
• Digital inputs: 0 V to + 5 V

Note: Values greater than these limits entered into the final test system connections to the
hardware may cause permanent damage to the final test board.

The bq27x00 Test and Program system requires the host PC to be connected to the final test board using
RS-232. The power supply is connected to the connector on the side of the final test board, as shown in
Figure 1. The test head (test fixture) can be constructed following the interface connection table in section
2.3.1 using a schematic and assembly drawing for the module to be tested. It is recommended that test
head cables not exceed 12 inches in length. Spring-loaded test pins are recommended for module testing.
Connection of test head to module requires precision contacts to ensure good electrical contact.

Figure 1. bq27x00 Test and Program Board
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2.4 System Power Up

3 Software Contents and Installation

3.1 Software Contents

3.2 Software Installation

Software Contents and Installation

2.3.1 Test Head Fixture Interface

The test head interface for the bq27x00 Test and Program board requires a Molex female 6-pin connector
#22-01-3067 with crimp terminals (tin) #08-50-0114. Table 1 contains data pertaining to the test points. If
testing bq27000 modules, then the wire used for the SCL communication pin is not connected.

Table 1. Test Points

bq27000 bq27200
MOLEX

WIRE GAUGE WIRE GAUGECONNECTOR DESCRIPTION
COLOR CODE INSULATED COLOR CODE INSULATEDPIN

(12 INCHES) (12 INCHES)

1 BATT– Black 22 AWG Black 22 AWG

2 HDQ/SDA Brown 22 AWG Brown 22 AWG

3 SCL N/A N/A Blue 22 AWG

4 PROG White 22 AWG White 22 AWG

5 PACK+ Red 22 AWG Red 22 AWG

6 PACK– Black 22 AWG Black 22 AWG

2.3.2 Computer to Test System Interface

Connect the bq27x00 Test and Program board to the computer communication port using the RS-232
cable.

After all connections are made, the final test board is powered with a power supply that provides +9 V to
+12 V DC (minimum 1 A) into the jack located on the side of the test board. Visually verify the green LED
labeled D11 is ON. Power can also be applied using an external power supply between +9 V to +12 V DC
(minimum 1 A).

The bq27x00 Tester Kit contains all software on a CD ROM as follows:

1. Documentation

a. bq27x00 User's Guide (SLUU227A)
b. bq27000, bq27200 Data Sheet (SLUS556)
c. HPA048 Schematic
d. HPA048 Top Assembly
e. HPA048 Bill of Materials
f. PIC Program V402 hex

2. Install Executable Program

a. CAB Files
b. setup.exe
c. bq27x00.gg Default EEPROM File

3. Visual Basic Source Code
4. ReadMeFirst.txt File

Use the following steps to install the bq27x00 Test and Program software:

1. Insert the CD ROM into a CD ROM drive.
2. Select the CD ROM drive using My Computer or File Manager.

SLUU227–December 2005 bq27x00 Single-Cell Battery Fuel Gauge Module Tester and Programmer 3

http://www-s.ti.com/sc/techlit/SLUU227


www.ti.com

4 Operation

4.1 Starting the Program

4.2 Initialization

Operation

3. Select the ReadMeFirst.txt File. Follow the instructions in file.
4. The setup program installs a Windows application group.

The bq27x00 Test and Program board verifies assembly functions for the RBI pin, Sense Resistor, and
Battery pin, while also programming EEPROM data.

Perform module tests before pack tests so that complete calibration and functional testing is accomplished
prior to pack assembly. The bq27x00 test board is for module test only. Do not attempt to use for pack
test.

Run the program from the Start|Programs|Texas Instruments|bq27x00 Tester menu sequence. If the
bq27x00 Test and Program board is connected to the RS-232 port, the program loads and displays the
initial Test Menu Screen shown in Figure 2. The Options menu may be used to select the communication
port and to select the product (bq27000 or bq27200) to be tested. The product type to be tested will be
displayed on the Test Menu screen.

Figure 2. Test Menu Screen

This section describes the settings that must be made before testing with bq27x00.

bq27x00 Single-Cell Battery Fuel Gauge Module Tester and Programmer4 SLUU227–December 2005



www.ti.com

4.3 Engineering

Operation

4.2.1 Load EEPROM

Click on the Load EEPROM selection. The Load EEPROM screen appears as shown in Figure 3. From
the menu bar, select File → Open Gas Gauge EEPROM Constants. Find the directory where the desired
configuration file is located, and select the file. Once you have selected the configuration file, click on Test
Menu, and skip to section 4.4 to begin testing. The Native_example.gg and Engineering_example.gg files
are provided as examples of what format must the EEPROM files follow.

Note: Do not attempt to change the configuration data while in the Load EEPROM menu
selection. See section 4.3.2 to modify and save configuration files.

Figure 3. Load EEPROM Screen

The Engineering section is a password-protected menu providing the opportunity to change the
configuration file or enable/disable specific tests. This menu is for engineering debugging in a production
test environment.

4.3.1 Password

Selecting the Engineering option brings up a password entry selection. Enter bmrq in the password field;
the User ID field is left blank. It is recommended that the password be changed once the system is ready
for production test. Use the menu bar, and select Options to change the password.

If the password is modified and the new password is not known, the bq27x00.exe must be reloaded where
the password is now the default.
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Operation

4.3.2 Test Selection Options

The Engineering screen is now present as shown in Figure 4. In this section, use the menu bar to select
File → Open Gas Gauge EEPROM Constants. Find the directory where the bq27x00.gg file is located,
and select the file. Configuration data can be modified and saved to a file but only in the Engineering
menu selection. Using the mouse, click on the data to modify, and after updating the field, press the Enter
key. Select Save Gas Gauge EEPROM Constants from the File menu, and enter a file name to save the
new configuration file. Once the configuration file has been selected or saved, click on Test Menu, and go
to section 4.4 to begin testing modules.

Figure 4. Engineering Screen
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4.4 Production Test

Operation

At this time, power to the bq27x00 Test and Program board is on, and testing can begin. Figure 5 displays
an example of the status and results when testing a passing module.

Figure 5. Test Menu Results Screen

4.4.1 Start and Stop Functions

The Start icon on the Test Menu screen is used to begin testing the module. The test results appear on
the screen after each test selected with either a PASS or FAIL indication. The Stop icon immediately stops
the test, and the Results section will not be updated.

4.4.2 Display Definitions

Completed status of the module under test is indicated with a green PASS or red FAIL condition.

Results: Displays and keeps running totals of modules tested.

1. Serial Number: Displays the last serial number tested.
2. Total Pass: Displays the total number of good modules.
3. Total Fail: Displays the total number of rejected modules.
4. Total Yield: Displays the total good divided by the total tested on a percentage basis.
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4.5 Pass/Fail Status

5 Test Descriptions for bq27x00

5.1 Theory of Operation for bq27x00

Test Descriptions for bq27x00

4.5.1 Data Logging

Data is logged on the computer monitor and can also be placed in a lot summary data file. After all testing
has been completed, the results can be stored in a .SUMMARY file. From the Menu bar, select → File Log
Test Summary. A prompt asks for a file name; at this time, select a directory where the test summary data
log file will be placed. The lot summary data log file is recommended during production test to keep
information stored on a by-lot basis.

Note: The program does not log the data into a .SUMMARY file until all testing is complete.

4.5.2 Example Data Log .SUMMARY File

Texas Instruments bq27x00 Gas Gauge Production Test Summary
bq27x00 Version 1.0.0
9/24/2003 4:14:02 PM

[Production Test Summary]

Serial Number from 1 to 4

Total Pass=3
Total Fail=1
Total Tested=4
Yield=75%

[Module Pass/Fail Summary]

Pass = 3
Fail BAT Pin=0
Fail Sense Resistor=1
Fail EE Verification=0
Fail RBI Pin=0

This section contains a brief description of the bq27x00 Module Test procedures. Power supply voltage to
Pack + (VCC) equals 3.8 V ±20 mV.

5.1.1 BAT Pin Test

Verify the VOLTH and VOLTL registers contain the reported battery voltage measured on the BAT pin. It
is important to wait for the device to complete a full conversion, approximately 2.56 seconds, before taking
a measurement. The program is set up to read back 3.8 V ± 300 mV from the specified registers.

5.1.2 Sense Resistor Test

Verify that the sense resistor is functioning properly with the following procedure:

1. Read Discharge Counts Register (DCR) from address registers 0x30 and 0x31, record the values, and
store in DCR counts Original.

2. Source current on Pack – to generate DCR counts.
3. Read DCR from address registers 0x30 and 0x31, record the values, and store in DCR counts Final.
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Test Descriptions for bq27x00

4. Compare absolute DCR counts Final minus DCR counts Original, and check for a specified range of
valid DCR counts for the sense resistor value used.

5.1.3 EEPROM Programming
1. Enable the programming mode by writing data 0xDD to the EE_EN register (addr 0x6E).
2. Latch data by performing a Write, then Read operation from the .gg configuration file.
3. Apply 21 V to PGM pin to program latched EEPROM data into the gas gauge.
4. Read verify from EEPROM registers for values equal to the .gg configuration file.
5. Disable the programming mode by writing data 0x00 to the EE_EN register (addr 0x6E).

5.1.4 RBI Pin Test

Verify that the RBI pin provides backup power to the internal registers when VCC drops below the
power-on-reset (POR) voltage. The test procedure is as follows:

1. Write data 0xA5 to At Rate register 0x02.
2. Write data 0x5A to At Rate register 0x03.
3. Enable WRTNAC bit in Mode register 0x01.
4. Write 0xA9 to Device Control register 0x00, which clears the POR bit.
5. Read Control Register 0x00 until the register has cleared.
6. Generate POR condition by turning Pack+ OFF for 200 ms.
7. Turn Pack+ ON, and read Mode register 0x01 to verify the POR bit has been set.
8. Read and store the values from NAC registers 0x0C and 0x0D.
9. Verify NAC register values retained the data written in the foregoing steps 1 and 2.
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IMPORTANT NOTICE

Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, modifications,
enhancements, improvements, and other changes to its products and services at any time and to discontinue
any product or service without notice. Customers should obtain the latest relevant information before placing
orders and should verify that such information is current and complete. All products are sold subject to TI’s terms
and conditions of sale supplied at the time of order acknowledgment.

TI warrants performance of its hardware products to the specifications applicable at the time of sale in
accordance with TI’s standard warranty. Testing and other quality control techniques are used to the extent TI
deems necessary to support this warranty. Except where mandated by government requirements, testing of all
parameters of each product is not necessarily performed.

TI assumes no liability for applications assistance or customer product design. Customers are responsible for
their products and applications using TI components. To minimize the risks associated with customer products
and applications, customers should provide adequate design and operating safeguards.

TI does not warrant or represent that any license, either express or implied, is granted under any TI patent right,
copyright, mask work right, or other TI intellectual property right relating to any combination, machine, or process
in which TI products or services are used. Information published by TI regarding third-party products or services
does not constitute a license from TI to use such products or services or a warranty or endorsement thereof.
Use of such information may require a license from a third party under the patents or other intellectual property
of the third party, or a license from TI under the patents or other intellectual property of TI.

Reproduction of information in TI data books or data sheets is permissible only if reproduction is without
alteration and is accompanied by all associated warranties, conditions, limitations, and notices. Reproduction
of this information with alteration is an unfair and deceptive business practice. TI is not responsible or liable for
such altered documentation.

Resale of TI products or services with statements different from or beyond the parameters  stated by TI for that
product or service voids all express and any implied warranties for the associated TI product or service and
is an unfair and deceptive business practice. TI is not responsible or liable for any such statements.

Following are URLs where you can obtain information on other Texas Instruments products and application
solutions:

Products Applications

Amplifiers amplifier.ti.com Audio www.ti.com/audio

Data Converters dataconverter.ti.com Automotive www.ti.com/automotive

DSP dsp.ti.com Broadband www.ti.com/broadband

Interface interface.ti.com Digital Control www.ti.com/digitalcontrol

Logic logic.ti.com Military www.ti.com/military

Power Mgmt power.ti.com Optical Networking www.ti.com/opticalnetwork

Microcontrollers microcontroller.ti.com Security www.ti.com/security

Telephony www.ti.com/telephony

Video & Imaging www.ti.com/video

Wireless www.ti.com/wireless

Mailing Address: Texas Instruments

Post Office Box 655303 Dallas, Texas 75265

Copyright  2005, Texas Instruments Incorporated
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